CGAL library not found (though installed)

I installed CGAL from source and it installed at /usr/local/include/CGAL/ Then when I try to build graph-tools (both 2.26 and the source from git) give me CGAl not found error. They do seem to be checking in the /usr/local directory but don't seem to find it..I have attached a log.

Is there something I should keep in mind while installing CGAL ?

attachment.html (2.36 KB)

LOG.txt (8.08 KB)

Ni! Hi Ganesh,

`./configure` generates a file called "config.log" when run, that is the
file you want to transmit when asking for help. A copy/paste of your
terminal is not nearly as useful.

Meanwhile, I assume you passed the parameter " --with-cgal=/usr/local/" to
`./configure`, is that right ?


attachment.html (2.09 KB)

Hi Ale

Attached is the copy of the log

attachment.html (5.81 KB)

config.log (89.9 KB)

Ok, I see you've passed the flag and configure is indeed looking for CGAL
at /usr/local/lib...

So it might be that CGAL got installed to /usr/local/lib64 instead.

If that is the case, try adding to your LDFLAGS:


and perhaps also:



attachment.html (5.31 KB)

Thanks Alexandre

I was able to run the ./configure successfully.
The only warning I got was “configure: WARNING: No usable boost::coroutine found! Some functionality will be disabled in the library.”
And then when I run make, it fails.
I have attached the new config.log and the output of the make.

Any guidance is much appreciated

attachment.html (11.4 KB)

config.log (91.6 KB)

make.log (416 KB)

Hey Ganesh,

Your make.log tells us the error you're getting is related to an ambiguous
definition of function `vertex` in `graph_reverse.hh`. (More specifically
when `graph_traits<BidirectionalGraph>::vertices_size_type` and `size_t`

One of the definitions has been removed in the development version of
graph-tool, and your config.log tells us you're compiling the latest (2.26)

So my guess is that this could be an incompatibility introduced by changes
in boost or the compiler since that release, which has already been taken
care of in the master branch. Though I haven't actually tried to compile
the release to see if I get the same error. We'd have to see what Tiago can
say about that more precisely.

Meanwhile, you can try compiling the latest git version of graph-tool <;, which shouldn't have this
problem. Just notice for that you'll need to run `./` before
running `./configure`.


attachment.html (10.2 KB)