Python interpreter too old?

I am trying to install graph-tools, I am using an anaconda version of python 2.7, and for some reason the graph-tools configure throws an error that this version of python is too old:

Z:graph-tool-2.2.31 g$ ./configure PYTHON="/g/anaconda/bin/python2.7" CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib"
checking whether /g/anaconda/bin/python2.7 version is >= 2.6... no
configure: error: Python interpreter is too old

Wherever possible I install python packages to anaconda’s interpreter and directories.

I use home-brew to install everything else…including boost.

In case it helps, I’ve also attached the log file.

Any direction would be appreciated.


attachment.html (1.26 KB)

config.log (72.2 KB)

attachment.html (204 Bytes)

./configure: line 16571: /g/anaconda/bin/python2.7: No such file or directory

Also note that boost-python must be compiled against the same python
version with which you intend to use graph-tool.


Thanks for the prompt response. However, I am now getting the error that no usable boost::python was found…

I’ve attached the latest log file.

config.log (97.4 KB)

Do you have boost-python installed? If so, how is the library called and
in what directory does it reside?


I installed boost using home-brew:
brew install —with-c++11 —build-from-source-boost

It resides in:

but has an alias / link from:


In what directory is the shared object file? It should be called
something like libboost_python.dylib. You should pass that directory to
the LDFLAGS when running the configure script.

Hi, I was unable to find the file…perhaps some sort of complication when boost installs with a non system python location active.

I’ve decided to uninstall home-brew and go with the mac ports route instead. Thanks.