Installation problem on Ubuntu 14.04 Trusty Tahr

Hello, my name is Arindam Nandi, and I have been using the grpah-tool module
for a college project. It was working absolutely fine on Ubuntu 13.04.

Yesterday, I upgraded to the 14.04 LTS release of Ubuntu and tried
installing the module the same way I did before, following the directions in
your downloads page for Ubuntu. I added the lines

deb trusty universe
deb-src trusty universe

to /etc/apt/sources.list, updated the repositories and then tried to install

sudo apt-get install python3-graph-tool

But its giving me the following error:

The following packages have unmet dependencies:
python3-graph-tool : Depends: libpython3.3 (>= 3.3.3) but it is not
E: Unable to correct problems, you have held broken packages.

python-graph-tool is getting installed fine, but all my code is in Python3.
I am a relative newbie to linux, so I am having trouble understanding what
the problem is here, any help will be appreciated.


It seems they removed python 3.3 and replaced it with 3.4 prior to the
release. I'll need to rebuild the packages. I'll do so for the next
release of graph-tool (which will be soon).


Yes, I guessed that Python 3.4 was the problem, I tried installing Python 3.3
and compiling the graph-tool package from source, but I kept getting errors
during ./configure regarding the Python version. Anyway, thank you for the
help! I have reverted to Raring for now.