error with manual compilation


I tried to intall graph-tool on my mac, but failed....
cmd I typied is:
./configure --prefix=/Users/zhangxuejin/anaconda

I have attached the configure.log and entire output of the ./configure
script as configure.out.

But I am sure that I have installed boost-python:
My packages in environment at /Users/zhangxuejin/anaconda:
boost 1.65.1 py36_4 anaconda
boost-cpp 1.65.1 1 conda-forge
boost-python 1.55.0 0 meznom
libboost 1.65.1 hcc95346_4

I also tried install like:
./configure --prefix=/Users/zhangxuejin/anaconda
--with-boost-python=-mt.a PYTHON=/Users/zhangxuejin/anaconda/bin/python

but same error msg appeared...

Please help with installation. Thank you very much!

attachment.html (1.5 KB)

config.log (100 KB)

configure.out (8.06 KB)

The above is wrong for several reasons. First CPPFLAGS and LDFLAGS are
invalid. They must be compiler/linker flags, not just directories. This
means that they should be CPPFLAGS="-I/Users/zhangxuejin/anaconda/include"
and LDFLAGS="-L/Users/zhangxuejin/anaconda/lib". Furthermore,
"-with-boost-python=-mt.a" does not make any sense, as this would point to
statically shared object.

Please take a careful look at the documentation:

Compiling graph-tool (or any other C++ library) without understanding how
compiling and linking works in general is not advisable. Instead you should
use macports or homebrew, if using MacOS.



I have tried macports or homebrew before, they don’t not work either. I do
not like to compile it myself either, but it seems that compiling is the
only option.


attachment.html (3.12 KB)

If you have problems with macports or homebrew, you should open an issue in
their respective websites. Any issue encountered is usually easy to solve,
and the developers tend to be helpful.


Sure, I will try it. Thanks :slight_smile:

attachment.html (1.48 KB)