Copy a graph that have no properties

Given start point and end point pairs of graphs, I try to find all_paths using Ray(python multiprocessing library).

It works with single processing, but when I give my graph to Ray, it gives me error like below.

RuntimeError: Pickling of "graph_tool.libgraph_tool_core.Vertex" instances is not enabled (

My Graph firstly created with vetex_properties of bools.

fullGraph.vp.start = fullGraph.new_vertex_property("int")
fullGraph.vp.end = fullGraph.new_vertex_property("int")

then filtered out to get subGraphs

component_labels = label_components(fullGraph, directed=False)[0]
subGraph = GraphView(fullGraph, vfilt=component_labels.a == idx)

then, I run all_paths algorithm with my subGraph in ray task, but it seems I should not have properties.

So is there a way that to duplicate a graph without properties?

(I have already tried with “subG=GraphView(subGraph, skip_properties=True).copy()”, but gives me same error)


When you post a new message to this forum you encounter a template that says:

If you are reporting on a problem, don’t forget to include:

  1. Your exact graph-tool version.
  2. Your operating system.
  3. A minimal working example that shows the problem.

Could you please follow the instructions, in particular point 3? There is a reason why we ask this, namely it’s impossible to understand error messages without context.

Also, please use triple back-ticks ``` to post code, not >>>. See here: Markdown Reference