compiling error: pycairo headers not found

Dear Tiago,

while trying to compile graph-tool for anaconda3 and python 3 we came across
following error message:
configure: error: pycairo headers not found

I ran the following command:
./configure --with-boost=/usr/local/anaconda3 --enable-openmp

Python3 is installed in /usr/local/anaconda3/bin and typing in python starts
the correct version.

The pycairo headers (py3cairo.h) are located in:

I am surprised it can't pick the file up, because it seems to pick up other
files from /usr/local/anaconda3/include.

Do you have any idea what we could have missed?

The config.log
is attached and I am running Ubuntu 16.04.

Many thanks,

Dear Jana,

Please read the compilation instructions more carefully:

Since you are installing things in a nonstandard directory, you need to
specify it using --prefix. In your case it should be:

    ./configure --prefix=/usr/local/anaconda3


Dear Tiago,

Thank you for your fast reply.

The new configure command I used was therefore:

./configure --prefix=/usr/local/anaconda3 --with-boost=/usr/local/anaconda3 --enable-openmp

Unfortunately, the problem wasn’t solved. The new config.log is attached:

Do you have another idea what might help the configuration?

Best wishes,

attachment.html (1.8 KB)

config.log (101 KB)

attachment.html (17.7 KB)