2011/10/11 Tiago de Paula Peixoto <tiago@skewed.de>

I loaded your graph, and saved it in both formats and everything came
out fine. I even tried on an ubuntu machine, and everything worked just
as well.

I have been saving and loading graphs repeatedly, on diverse machines
(with Gentoo, Debian, MacOS), clusters nodes, etc, and I've never
observed this problem.

I'm inclined to believe this is due to something peculiar on your
setup. The fact it is running on a virtual machine is maybe
relevant... Have you observed any other problems?

Besides the bug I submitted a while ago, this is the first serious  problem  I'm having with graph_tool. It is possible that the problem may be located in the C++ back end used for reading/writing? I mean, some corrupt C++ library recently installed on my machine.
Also, it seems strange mostly because smaller hand made graphs seems not to be affected by this issue.

The only other thing that comes to my mind is a problem evaluating the average shortest path on the graph: as you can see from the file, the number is a bit wrong, but I tested it again on that machine (the virtualbox one) and I'm inclined to think that there was a bug on the script that generated the value (on another machine, a plain simple debian stable running graph_tool 2.2.14).

Thanks anyways,