Sorry that I didn't provide everything that you asked for. Yes I am installing gt on newly installed Ubuntu17.10 and running `locate libpython`, among other things, gives me:


Thus, the version 3.6 seems to be installed and I guess I need 3.5. Is that right?

Sent with ProtonMail Secure Email.

-------- Original Message --------
On January 24, 2018 3:59 PM, Alexandre Hannud Abdo <> wrote:

Well, I'll ask again: are you installing on a new clean install of Ubuntu?

Also, the package you're having trouble with is not Python, it's libpython. Do you have libpython installed? What version? Did you try reinstalling it?

If you don't provide us with detailed information, we can't do much to help you.


On Wed, Jan 24, 2018 at 4:51 PM, Snehal Shekatkar <> wrote:
Unfortunately, installing Python3.5 didn't help me. Still throws the same error.

Sent with ProtonMail Secure Email.

-------- Original Message --------
On January 24, 2018 11:48 AM, Alexandre Hannud Abdo <> wrote:

Ni! Hi Snehal,

Do you mean you tried this command on a new clean install of Ubuntu, nothing else been done previously to it? - other than enabling he PPA and updating the system, I'd guess.

Otherwise, this may not be related to graph-tool at all, you just need to figure out why libpython is not installable.

(Did you already try any solution after searching the net for the error message? For example, reinstalling python3 and the respective libpython? Or calling install with aptitude instead of apt?)


On Wednesday, January 24, 2018, Snehal Shekatkar <> wrote:
Dear Tiago,

I am trying to install graph-tool on ubuntu17.10 and I get the following error:

sudo apt-get install python3-graph-tool

The following packages have unmet dependencies:
python3-graph-tool : Depends: libpython3.5 (>= 3.5.0~b1) but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I fix this?

Thank you

Snehal M. Shekatkar

graph-tool mailing list