Ubuntu 14.04 and Boost::Coroutine Library


I read the discussions and suggestions regarding this topic but still
struggle with the Boost Coroutine Lib. I built the Boost Library 1.55 (and
afterwards also 1.60) without errors from source. The Libs were built into
the directory /usr/local/lib and the corresponding header files are located
in /usr/local/include/boost. Especially, the file libboost_coroutine.so
(versions 1.55.0 and 1.60.0 and a link libboost_coroutine.so) is available
in /usr/local/lib.

Afterwards, I tried to configure the graph-tool project (following the
advices in
) with the command ./configure LDFLAGS="-L/usr/local/lib" CPPFLAGS
="-I/usr/local/include/boost/". But I still get the message "checking
whether the Boost::Coroutine library is available... no configure: WARNING:
No usable boost::coroutine found! Some functionality will be disabled in the
library" (see attached config.log).

Am I miss an obvious aspect? Thank you in advance.

Best regards,

Sorry, the attached file was accidently placed in the body of the text. The
command I used:

./configure LDFLAGS="-L/usr/local/lib"

Try with

   ./configure LDFLAGS="-L/usr/local/lib" CPPFLAGS="-I/usr/local/include"


Thank you for your immediate response. Unfortunately, the command you
suggested result in the same outcome.


I noticed from your config.log that the preprocessor flags for boost are
overriding the ones that you supplied with "-I/usr/include".

Could you try with the new 2.18 version, that has new autoconf macros
for boost?

If that does not work, just please try the current git version, where I
make sure that user-supplied flags are prioritized.


The version 2.18 gives the same error: config.log

And I am not able to checkout the git repo, because git is requesting a
password 'gitlab(a)git.skewed.de's password:' and I did not find one in the
graph-tools docu (and it is not empty :slight_smile: ).

Thank you very much for your support!

You can checkout from https if you do not have an account:

    git clone https://git.skewed.de/count0/graph-tool.git

Sorry, I overlooked the download button at the git repo's website. But
unfortunately, it does not work. I have tried regularly for the last 20
minutes and always get HTTP error 500 (internal server error). I will try
again and if I am able to download I will report the outcome of ./configure
of that graph-tool version.

Thank you!

You should just do:

    git clone https://git.skewed.de/count0/graph-tool.git

which will work.

I'll investigate the issue with the download button.


I'm sorry wasting your time ... in graph-tool 2.19 directory there is no
configure script and I was not able to create one with autoconf using

You need to run ./autogen.sh first.

Hello Tiago,

it is the same outcome with the 2.19 version of graph-tool. Here is the log:

May I miss something else? The shared object file definitely is in

Best regards,

Did you run ./autogen.sh again after updating graph-tool from git?

If yes, please post in detail _all_ commands and their outputs.


Hello Tiago,

yes, I did. But to be sure, today, I started all from scratch:

I built boost_1.55 again. Afterwards, the libboost_coroutine.so is in
directory /usr/local/lib and the headers are in /usr/local/include/boost.

I downloaded graph-tool from git via the command you suggested:
git clone https://git.skewed.de/count0/graph-tool.git

I changed to that directory:
cd /home/adminuser/graph-tool

Then, I ran the ./autogen.sh command
It produced this output: gt-autogen-out.log

And finally, I ran configure:
./configure CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib"
It produced this output: gt-configure-out.log

That´s it. Do you need further information? Do you check with "configure"
just the existence of necessary librariers or also their expected
functionality? If the latter is true I will try to check the
libboost_coroutine.so with a simple application to be sure it is working as
it should.

Thanks a lot!