Segmentation fault when running the animation scripts in the Cookbook section

Dear all,

I am new to graph tool. I have installed it under Ubuntu 14.04 64-bit and Python 2.7. When I tried to run the animation demos in the Cookbook section of the documentation I got a segmentation fault error. I loaded the core with gdb but couldnt get any further details on the source of the error.

Stepping into the code I managed to find out that the segmentation fault takes place when win.graph.regenerate_surface() is executed, e.g. On line 122 in Gtk seems to be using TkAgg for what it matters.

Do you have any idea on why this error occurs? Shall I try another GTK backend?

Kind regards

attachment.html (877 Bytes)

Unfortunately, it is very hard to say anything without a backtrace. You
need to give more detailed information. I don't observe any segfaults
with the animation examples.

Also, I'm not sure what you mean with "another GTK backend". TKAgg is
not a GTK backend, it is a matplotlib backend.


Hi Tiago

Thank you for the reply and for putting together this library.

Unfortunately, I 'm not good at Linux could you give me a pointer on how to produce the backtrace?

Yeah forget about the TkAgg wrong wording :wink:

All best

Στις 20 Σεπ 2015 9:04 ΜΜ, ο χρήστης Tiago de Paula Peixoto <tiago(a)> έγραψε:

You have to isolate the problem in a self-contained script first. If it
happens in one the animation scripts, you have to say which one.

Then you run the script under gdb:

    gdb python
    (gdb) set args ./
    (gdb) run

when the segfault occurs you type

    (gdb) bt

and post the _entire_ result.


Hi Tiago,

Thanks for the tips. Both the animation scripts throw segmentation fault but I am running the example with ````. I am attaching the trace after the "bt" command plus a a few lines before that, because I observed an ImportError:
    from libstdcxx.v6.printers import register_libstdcxx_printers
ImportError: No module named 'libstdcxx'

Thank you in advance for the help

attachment.html (1.62 KB)

stacktrace.txt (2.34 KB)

Hi everyone on the list,

Sorry to knock the door again, I know the support is voluntary but I would really like to use graph-tool, so as a gentle reminder, does anyone have an idea why this segfault is appearing?

All best

attachment.html (2.43 KB)

stacktrace.txt (2.34 KB)

ATT00001.txt (144 Bytes)


After installing the binaries in a freshly installed Linux, I managed to run the demos without segmentation faults. In my first unsuccessful attempt I tried compiling he library, so apparently something was wrong with the configuration.

Congrats to Tiago and any other contributors for making this library available


attachment.html (3.48 KB)