pycairo problem in ./configure

Hi all,

I successfully compiled grpah-tool in my Mavericks OSX using homebrew for
the dependencies optional or not (i.e. expat, boost, cairo,...)

the configuration was

./configure LDFLAGS="-L/usr/local/Cellar"
CPPFLAGS="-I/usr/local/include/sparsehash" PYTHON_VERSION="2.7.6"
--enable-cgal-valgrind --disable-cairo

make and make install works fine here !!

attachment.html (2.6 KB)

config.log (95.2 KB)

my_conf.log.txt (40 KB)

actually he is looking fot the the pycairo.h in the directory
while in my systems it seems to be installed in

How I can pass mine pycairo.h directory to the configuration ?

attachment.html (3.23 KB)

The following should probably work:



Hi Tiago,
thanks for your response, but unfortunately it still does not work.
Actually, both directories
/usr/local/Cellar/py2cairo/1.10.0/include/pycairo/ and
/usr/local/include/pycairo contain a file pycairo.h.
So, I tried to pass each of these two directories to the CPPFLAGS, but I
am getting the same configuration error, ie.
checking pkg-config is at least version 0.9.0... yes
checking for CAIROMM... yes
checking python module: cairo... yes
checking pycairo/pycairo.h usability... no
checking pycairo/pycairo.h presence... no
checking for pycairo/pycairo.h... no
configure: error: pycairo headers not found

Then I have reinstall pycairo with brew uninstall py2cairo & brew install

and I tried again, but unsuccessfully,

Any other ideas?

attachment.html (1.79 KB)

The problem is almost certainly that your are not passing the correct
non-default include paths you are using via the CPPFLAGS variable; you
just need to find the correct ones. Search in the config.log file for
errors such as "fatal error: 'cairo.h' file not found", and include the
directory where such include files are to be found.

Just be careful to set the include paths which are compatible with the
libraries that you are linking to.


I manage to run configure correctly by giving the needed paths

./configure LDFLAGS=-L/usr/local/Cellar
--enable-cgal-valgrind CPPFLAGS=-I/usr/local/include/sparsehash
-I/usr/local/Cellar/cairo/1.12.16/include/cairo PYTHON_VERSION=2.7.6
-L/usr/local/Cellar/cairo/1.12.16/include/cairo CAIROMM_CFLAGS=-O3
-lcairomm-1.0 -lcairo -lsigc-2.0

However I take now a fatal error when I run make

Making all in draw
  CXX graph_cairo_draw.lo
clang: warning: -lcairomm-1.0: 'linker' input unused
clang: warning: -lcairo: 'linker' input unused
clang: warning: -lsigc-2.0: 'linker' input unused
warning: unknown warning option '-Wno-unused-local-typedefs'
[-Wunknown-warning-option] fatal error: 'cairommconfig.h' file not found
#include <cairommconfig.h>
1 warning and 1 error generated.
make[4]: *** [graph_cairo_draw.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

attachment.html (3.3 KB)

It seems you are still not including all the paths properly. Find where
the file cairoconfig.h is installed on or your system, and pass that
directory as the argument of the "-I" option in your CPPFLAGS variable.


I'm not sure if you had gotten it to work by now or not - I had the same
problem, but was able to fix it by changing /usr/include/pycairo/py3cairo.h
to /usr/include/pycairo/pycairo.h

attachment.html (3.14 KB)