OS X Macports clang with openmp build of graph-tool

Macports clang 3.7 and 3.8 now support openmp, which creates the opportunity
to build graph-tool on OS X with OpenMP speeds.I've tried the following,
which haven't quite worked yet, but it's close. Any pointers would be
sudo port uninstall py-graph-tool py27-graph-tool
sudo port clean --dist py-graph-tool py27-graph-tool

sudo port install clang-3.8 +openmp
sudo port -d install py-graph-tool py27-graph-tool
configure.compiler=macports-clang-3.8 configure.args=--enable-openmp
I expected the option "configure.args=--enable-openmp" would tell the
autoconf'd ./configure command to specify --enable-openmp, but it does not:
DEBUG: Executing command line: cd
&& ./configure --prefix=/opt/local --with-boost=/opt/local

checking whether to enable parallel algorithms with openmp... no
The port notes for clang-3.8 say:
Use with clang-3.[78] (when built with +openmp variant) by adding
"-fopenmp" to your compile and link lines.
(Or "-I/opt/local/include/libomp -L/opt/local/lib/libomp -fopenmp"
if clang is installed without +openmp.)
Based on the Port Phases
<https://guide.macports.org/chunked/reference.phases.htm&gt; page, I've tried
a variety of options like configure.cxxflags-append=-fopenmp, all without
success. Perhaps a custom portfile is necessary, but this would be easiest
to address through the port command line.

attachment.html (2.37 KB)

You should open a support ticket at the Macports website...




After patching the portfile to use --enable-open, I see compiler errors for
both clang-3.7 and clang-3.8 (posted at the macports ticket above). Macports
suggested based on the compiler errors that I upstream this issue to you.

Would you mind taking a look and seeing if you think this is an issue with

For those interested, Tiago patched OpenMP support for OS X into the latest
graph-tool, and it's really fast.

Thanks again Tiago!