(no subject)

Hi Tiago,

I installed graph-tool on a mac machine. After struggling a lot to import
graph_tool without any error in python, I was running an example with
plotting and I was getting following error

from graph_tool import all

/Users/zahra/anaconda3/lib/python3.6/site-packages/graph_tool/draw/cairo_draw.py:1494:
RuntimeWarning: Error importing Gtk module: No module named 'gi'; GTK+
drawing will not work.

  warnings.warn(msg, RuntimeWarning)

from graph_tool.all import *

g=Graph()

v1 = g.add_vertex(

... )

v2 = g.add_vertex()

e=g.add_edge(v1,v2)

graph_draw(g, vertex_text=g.vertex_index,

vertex_font_size=18,output_size=(200, 200), output="../two-nodes.png")

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

  File
"/Users/zahra/anaconda3/lib/python3.6/site-packages/graph_tool/draw/cairo_draw.py",
line 1185, in graph_draw

    nodesfirst, fit_view=fit_view, **kwargs)

  File
"/Users/zahra/anaconda3/lib/python3.6/site-packages/graph_tool/draw/cairo_draw.py",
line 707, in cairo_draw

    max_render_time, cr)

MemoryError

quit()

Well, googling this error did not help to solve the problem. Could you
please suggest a solution ?

Thanks in advance.

Cheers,
Zahra

attachment.html (5.75 KB)

Sorry for the lack of response after such a long time, but I haven't been
able to reproduce this problems in any of my systems.... Could you give me
mor information about your setup (OS, compiler, cairo version, etc.)?

Best,
Tiago

Tiago de Paula Peixoto <tiago(a)skewed.de>