libpython3.5 error on Ubuntu17.10

Dear Tiago,

I am trying to install graph-tool on ubuntu17.10 and I get the following

sudo apt-get install python3-graph-tool

The following packages have unmet dependencies:
python3-graph-tool : Depends: libpython3.5 (>= 3.5.0~b1) but it is not
E: Unable to correct problems, you have held broken packages.

How can I fix this?

Thank you

Snehal M. Shekatkar

attachment.html (818 Bytes)

Ni! Hi Snehal,

Do you mean you tried this command on a new clean install of Ubuntu,
nothing else been done previously to it? - other than enabling he PPA and
updating the system, I'd guess.

Otherwise, this may not be related to graph-tool at all, you just need to
figure out why libpython is not installable.

(Did you already try any solution after searching the net for the error
message? For example, reinstalling python3 and the respective libpython? Or
calling install with aptitude instead of apt?)


attachment.html (1.69 KB)

Unfortunately, installing Python3.5 didn't help me. Still throws the same error.

attachment.html (2.36 KB)