libcairomm1.0 dependency in debian squeeze


I tried to install the graph-tool .deb package in debian squeeze from
the following repository

deb squeeze main

but I cannot solve a libcairomm.10 dependency:

The following packages have unmet dependencies:
graph-tool : Depends: libcairomm-1.0 but it is not installable

However, I do have installed the appropriate debian packages which
should satisfy the dependency:

libcairomm-1.0-1 - C++ wrappers for Cairo (shared libraries)
libcairomm-1.0-dev - C++ wrappers for Cairo (development files)

The package dependencies are listed as:

Depends: libboost-iostreams1.42.0 (>= 1.42.0-1), libboost-python1.42.0
(>= 1.42.0-1), libboost-regex1.42.0 (>= 1.42.0-1), libc6 (>= 2.2.5),
libcairo2 (>= 1.2.4), libcairomm-1.0-1 (>= 1.6.4), libcgal5, libexpat1
(>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1),
libgcc1 (>= 1:4.1.1), libgmp3c2, libgomp1 (>= 4.2.1), libpng12-0 (>=
1.2.13-4), libpython2.6 (>= 2.6), libsigc++-2.0-0c2a (>= 2.0.2),
libstdc++6 (>= 4.4.0), libx11-6, zlib1g (>= 1:1.1.4), python-dev,
python-scipy, libgv-python, g++-4.4, libboost1.42-dev, expat,
python-matplotlib, libcairomm-1.0, python-cairo

Among which are libcairomm-1.0-1 (which is installed) and
libcairomm-1.0 (that is not installed).

What are the differences between these two packages?

For the record, I did install previous versions of graph-tool in
debian squeeze.



Hi Rodrigo,

Excellent, thanks!