Installation issue on AWS

Hi all,

I wanted to install graph-tool to my AWS sagemaker notebook. I have tried
all installers available on, but none worked... Please see one
examples below:

conda install -n python3 -c ostrokach-forge/label/dev graph-tool

Solving environment: failed

PackagesNotFoundError: The following packages are not available from current

  - graph-tool
  - cairomm
  - graph-tool
  - cgal=4.11
  - graph-tool
  - sparsehash

Current channels:


Which channels do I need to add to solve this issue?

Thank you!

There is now graph-tool package available on conda-forge. Could you
try removing
the ostrokach-forge channel from your .condarc file and running:

conda create -n graph-tool -c conda-forge graph-tool

attachment.html (3.72 KB)

Hello, thanks for your prompt reply.

The command you provided worked, but the problem is that any new environment
I create on AWS will get deleted every time when I restart the notebook
instance. I need to install it in one of the default environments. For
example, if I install it in tensorflow_p36 using 'conda install -c
conda-forge graph-tool', it stuck at solving environment step forever...

(tensorflow_p36) sh-4.2$ conda install -c conda-forge graph-tool
Solving environment: -

Do you know why it got stuck?

I also tried installing it in one of the environments on my linux machine
using 'conda install -c conda-forge graph-tool', but got a bunch of package


The correct forum for these questions is the conda-forge graph-tool project:


Hi, I have the same problem. Did you ever find a solution, redBlackTree?

I have been going through every option in
and so far none of them have worked.