Debian package and boost at compile-time

Thank you for all the advice. I shall compile them all then. Do the
currently installed boos libraries need deleting?

It is possible to have them installed in parallel.

Note however that the process of compiling and installing boost is
somewhat convoluted. If it is your first time doing this, it might take
a bit of work.

Also, please do not post questions here about how to solve problems with
the boost installation, since it is off topic; you should try the boost
mailing lists instead.

Simply uninstalling and then re-installing graph-tool with apt-get
will not pick up the correct libraries presuming I have installed them
beforehand I take it?

No. As I said, the library needs to be recompiled.


Hopefully final question on this matter:

I have compiled boost and now need to point the graph-tool ./compile command
to the correct location. I presume this is the --with-boost option? What
target am I looking for here? I have compiled boost to
"/home/pmj27/software/boost1.60" which includes a "lib" and an "include"
directory. Are there any other options that I need to pass so that it uses
the correct boost version?

You do not need to set the --with-boost option. You should only have to
pass the following environment variables to configure:


Also, you must set the variable:


before you import the library, after compilation.


It does not seem to pick up the boost::coroutine library like that yet. Is
this an issue of boost not being correctly linked to Python or an issue of
./configure not finding the correct file?

Also, how do I pass multiple CPPFLAGS? My current command is (I have run it
without the py2cairo instructions to see if that caused the problem, it

CPPFLAGS="-I/home/pmj27/software/boost1.60/lib" CXX='g++-5'

Here is the config.log file.

config.log (105 KB)

You have to put everything in a single line.

It is all in a single line in the terminal window, the message just split it
across several lines so the issue is not caused by that.

Ok, but you should not repeat the declaration of the same variable
twice, since the second declaration overrides the previous one. It should
be instead:

   ./configure CPPFLAGS="-I/home/pmj27/anaconda2/pkgs/py2cairo-1.10.0-py27_2/include/ -I/home/pmj27/software/boost1.60/lib" LDFLAGS="-L/home/pmj27/software/boost1.60/lib" CXX="g++-5"

I just noticed that your include path for boost is obviously wrong. It
should have been:

     ./configure CPPFLAGS="-I/home/pmj27/anaconda2/pkgs/py2cairo-1.10.0-py27_2/include/ -I/home/pmj27/software/boost1.60/include" LDFLAGS="-L/home/pmj27/software/boost1.60/lib" CXX="g++-5"

Ahh, thank you! I shall attempt that.

It now runs without errors, but bizarrely I get the following (contradictory?) warning:

checking whether the Boost::Coroutine library is available... yes
configure: WARNING: No usable boost::coroutine found! Some functionality will be disabled in the library.

Any thoughts why?



config.log (116 KB)