Compiling Error

Hi Tiago,

I'm very interested in using graph-tools to do network analysis since my
network is pretty large. After I installed those required dependency
packages, I still got errors when I run make. The error message is as
following which I could not figure out.

./configure CPPFLAGS="-I/home/gaol3/Software/Tools/boost/include
-L/home/gaol3/Software/Tools/CGAL/lib" --disable-sparsehash

make[4]: *** [graph_hits.lo] Error 1
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
make: *** [all] Error 2


Please post the *entire* output of ./configure and make, as well as the
contents of the config.log file, otherwise it is not possible to say
what is going on.



Sorry for the confusion! Attached are those files you may need, and please
take a look.

Long config.log

Thanks for the detailed information.

This is an incompatibility bug with boost 1.60. This has been fixed in
git already, and the fix will be available also in the next release. In
the meantime, you should use the git version instead.


Hi Tiago,

Thank you for the advice! I think I successfully installed the graph-tool,
but it turned out a segmentation error when I entered "import graph_tool". I
saw someone also had the same error in another post, and I did something you
suggested in that post. Following is the output,

bash-4.2$ gdb python
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-80.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from
(gdb) run

Starting program: /home/gaol3/Software/Tools/Python/bin/python
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/".
Detaching after fork from child process 11698.
Detaching after fork from child process 11700.

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7de6976 in _dl_relocate_object () from
Missing separate debuginfos, use: debuginfo-install blas-3.4.2-5.el7.x86_64
glibc-2.17-106.el7_2.4.x86_64 jbigkit-libs-2.0-11.el7.x86_64
keyutils-libs-1.5.8-3.el7.x86_64 krb5-libs-1.13.2-10.el7.x86_64
lapack-3.4.2-5.el7.x86_64 libcom_err-1.42.9-7.el7.x86_64
libffi-3.0.13-16.el7.x86_64 libgcc-4.8.5-4.el7.x86_64
libgfortran-4.8.5-4.el7.x86_64 libjpeg-turbo-1.2.90-5.el7.x86_64
libquadmath-4.8.5-4.el7.x86_64 libselinux-2.2.2-6.el7.x86_64
libstdc++-4.8.5-4.el7.x86_64 libtiff-4.0.3-14.el7.x86_64
libuuid-2.23.2-26.el7.x86_64 openssl-libs-1.0.1e-51.el7_2.2.x86_64
pcre-8.32-15.el7.x86_64 python-libs-2.7.5-34.el7.x86_64
xz-libs-5.1.2-12alpha.el7.x86_64 zlib-1.2.7-15.el7.x86_64

Do you have any ideas about this segmentation error?