Building error on CentOS 6.8; ‘CoroGenerator’ was not declared in this scope

Hi all,

I'm experiencing the following error when trying to build graph-tool for
CentOS 6.8.

I am building graph tool on a docker image with the following configuration.
As can be seen in the following code running the configuration with

Dockerfile:

Already survived a lot of installation errors (because I know CentOS is not
the easiest platform to build for, but required to use it.), but I can't
find a solution to this error online and do not have enough knowledge of the
configuration error to solve it myself. I you could help me out I would
greatly appreciate it!

Thanks in advance,
Jelle

It seems to be a problem with boost coroutine. Could you please provide the
full output contents of the config.log file?

Best,
Tiago

Thanks for the fast response Tiago. In the attachment the config.log file. It
indeed logs:

I searched this problem and found
http://main-discussion-list-for-the-graph-tool-project.982480.n3.nabble.com/Debian-package-and-boost-at-compile-time-td4026383.html,
which suggest that boost 1.54 does not have coroutine yet, is this correct?

config.log
<http://main-discussion-list-for-the-graph-tool-project.982480.n3.nabble.com/file/n4027096/config.log&gt;

Yes, I believe boost 1.54 is too old. You have to use a newer version.

Best,
Tiago

Oke I will try with a newer version of boost. I will post if it is successful
or not.

Just to provide some feedback, the ./configure statement checks for boost
1.54,
although it is true that the Installation instructions page
<https://git.skewed.de/count0/graph-tool/wikis/installation-instructions&gt;
says boost >=1.55 is required. Shouldn't the configure script also require
boost >+1.55 then?

And thank for the great graph tool, it is very useful!

Oke I will try with a newer version of boost. I will post if it is successful
or not.

Just to provide some feedback, the ./configure statement checks for boost
1.54,
although it is true that the Installation instructions page
<https://git.skewed.de/count0/graph-tool/wikis/installation-instructions&gt;
says boost >=1.55 is required. Shouldn't the configure script also require
boost >+1.55 then?

Yes, this needs fixing. Will be done soon.

And thank for the great graph tool, it is very useful!

Thanks!