Boost.Python.ArgumentError: Python argument types did not match C++ signature

That is strange indeed. I have downgraded to the anaconda version of boost
(v1.60) and boost-python (v1.60) by sseefeld. The configure commands are
unchanged as ./configure --prefix=$HOME/.local
--with-boost=/home/pmj27/anaconda2 CXX="g++-5" CXXFLAGS="-std=gnu++14
-Wno-unused-local-typedefs" PYTHON="/home/pmj27/anaconda2/bin/python2.7"
LDFLAGS="-L/home/pmj27/anaconda2/lib" --enable-openmp which seems to still
run happily ( config.log
) but during make this boost configuration also complains, albeit
differently ( screengrab.dat
). Is there any way of narrowing down the root of the error?



Yes, the problem has to do with the order of the CPPFLAGS. I will be pushing
a fix to git soon.

Can you give me the full output of 'make V=1'?

Great, thanks! Here is the output of "make V=1 2>&1 | tee ./screengrab.dat"
rerunning it after the error had occured ( screengrab.dat
). If you would like the output for an entirely new compilation let me know
and I shall get that to you, it might just take a little while longer to

Please try the current git version.

It seems to still fail I fear. The screen output is huge but in the attached
file (
) you seem to be able to find the relevant error between lines 6824 and

Sorry, here is a more manageable file ( screengrab2.dat
) . I reran the failed make to get only the faulty bit with V=1. Do you have
any thoughts on why it is still failing?

Similar error on a different sysyem. I ran ./configure CXXFLAGS="-std=gnu++14
-Wno-unused-local-typedefs" PYTHON="/home/pmj27/anaconda2/bin/python2.7"
--enable-openmp --with-boost=/home/pmj27/anaconda2 so didn't have any

During make it crashes at the same spot it seems ( screengrab3.dat
). I am running boost 1.63.0 conda-forge.

Please try once more with current git. If it does not work, please open n
issue, so we don't overload the mailing list with another wack-a-mole.

This now compiles and works on one of my machines. My other machine now
complains about

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
line 111, in <module>
    dl_import("from . import libgraph_tool_core as libcore")
line 61, in dl_import
    exec(import_expr, local_dict, global_dict)
  File "<string>", line 1, in <module>
ImportError: cannot open shared object file: No such file
or directory

This may be an anaconda issue but I am not sure. Do you have any thoughts on
this? I will open a ticket for this so we can close this thread down.

This is not a bug in graph-tool. The linker cannot find that library. You
have to find where that is, and put its path into the LD_LIBRARY_PATH
environment variable. Or pass it as "-Wl,-rpath=", as explained in the