Anaconda looking for despite only version 54.1 being installed

I am trying to compile graph-tool on a machine of mine (Ubuntu 16.04, boost
1.60.0 and gcc 5.4.0) . To do this I am using

./configure CXXFLAGS="-std=gnu++14 -Wno-unused-local-typedefs"
PYTHON="/home/pmj27/anaconda2/bin/python2.7" --enable-openmp

When importing graph_tool.all in python, however, I get an error message as

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
line 111, in <module>
    dl_import("from . import libgraph_tool_core as libcore")
line 61, in dl_import
    exec(import_expr, local_dict, global_dict)
  File "<string>", line 1, in <module>
ImportError: cannot open shared object file: No such file
or directory

Checking for the location of `` (/home/pmj27/anaconda2/lib) I
have tried

./configure CXXFLAGS="-std=gnu++14 -Wno-unused-local-typedefs"
LDFLAGS="-L/home/pmj27/anaconda2/lib" --enable-openmp

this however returns the same error.

Checking `conda list` the icu version that is running is indeed only version
54.1 so I am not surprised that it cannot pick up version 56. I am wondering
though why it is looking for version 56 in the first place. My suspicion is
that this may be an anaconda issue introduced by some package but am not
100% sure. If it is an anaconda issue how would I go about tracking down
which package is causing it to try and import so that I can
see if there is a fix for it?

This is not a graph-tool problem at all, is it? I think you are better off
seeking help in an anaconda forum.

Simple question: Does the file exist at all in your system?

If you make a symbolic link ln -s in your
conda environment, it will probably work…

attachment.html (4.17 KB)

The symbolic link seems to have indeed solved the problem (though I also had
to do it for "" and ""). Thank you for the

I agree Tiago, this does not seem to be a problem caused in graph-tool
itself but anaconda comes with a lot of packages and thus a lot of possible
mailing lists so I was wondering how to tell which package was being called
when the issue arose so that I can go away and talk to the right people
about finding a fix/workaround. It seems like we have a workaround now